AVRUSB verify fail

Home Forums Kanda Forums Technical Support Forums AVRUSB verify fail

This topic is: not resolved

This topic contains 1 reply, has 2 voices, and was last updated by  Kanda Admin 5 years, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #346

    Sohma Tech
    Participant

    We just bought AVRUSB programmer to flash the radio firmware in our new product we connect the unit to the PC and to the unit using the JTAG adapter, we flashed the firmware and every things seems to be OK. I did device > Flash > verify and I got a lot of red bits in the application UI (AVRUSB Ver. 2.9.8.6) and it reports verification failed.

    I changed the Programmer ISP speed from highest to lowest and 2 other value between. I always get the same results, the only different was the flashing time.

    Is there any other parameters we need to set?

    #347

    Kanda Admin
    Keymaster
    Post count: 324

    Programmer speed should not be an issue, especially on JTAG, unless you have a very slow target clock or very low voltage. If changing ISP speed in Setup doesn’t work then it is likely to be one of the reasons given below.

    Three possible causes are

    1) Device is not Erased before programming

    2) USB latency is too low. Click Setup button at top right of screen and check USB latency is set to at least 16.

    3) Check EEPROM and flash timings are ok on setup screen. Click Default button in Setup screen.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Microcontrollers, training, electronics and coding