STK200 Quick Start Guide
Kit Contents
•
•
•
•
•

STK200 Board
Atmega16
AVRISP-U USB In System Programmer (ISP)
Software CD and AVR Datasheet CD
JTAGAVR - ICE kit only

The only extra item required is a power supply – see Power Supply section for details
about suitable power supplies.

Installing Software and documentation
The CD contains an executable file – Kanda AVR.exe. Run this installer and it will copy
all the documentation, sample code and software to your PC.
The default install folder for Kanda software and documentation is
C:\Program Files\Kanda AVR (Program Files(x86) on 64-bit PC)
This installer will install AVR Studio development environment. If you already have it on
your PC, click cancel for the installs (AVRStudio v4.19 and WinAVR C Compiler).
There are four main pieces of software:
•

AVRISP – This is the programmer software, used for transferring code from the PC
into the AVR device on the board. The Kanda AVR installer will install this software.

AVRISP has a Documents folder that contains PDF files with useful information about
AVRISP.
•

AVR Studio4 - AVR Studio is a complete development system for AVR devices,
supplied by Atmel. It is probably the best available for any microcontroller. This
environment is where you write new programs, and assemble them for the AVR chip.
It also allows you to step through your code to debug it, using JTAG ICE tool. The
documentation folder includes instructions on using AVR Studio.
A later version of AVRStudio, AVRStudio6, is available for free download from Atmel
site, but JTAG ICE debugger will not work in AVRStudio6. You also need a very fast
PC and lots of disk space as it is about 750 MB.

The installer allows you to install AVR Studio. Please let it install USB Jungo files as
these are the drivers for JTAG ICE. The default install path is
C:\Program Files\Atmel\AVR Tools\AVR Studio
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•

WINAVR - WINAVR is a C Compiler for AVR microcontrollers. Check box to install
WinAVR if you want to use C language for your AVR development. Documentation
is included. WinAVR will be automatically linked to AVR Studio.

•

App Builder – Wizard for creating setup code in assembler or C for AVR
peripherals.

Summary
The only software you need to install to start with are AVRStudio for code development,
WinAVR if you want to write in C and AVRISP for programming AVR devices on the
STK200 board. The other software and documentation is available if you need it.
AVRISP will be integrated into AVR Studio if AVRStudio is installed first. The
Kanda installer does this by default.

Getting Started
AVRISP is the In System Programming software, AVRStudio is the development
environment and the STK200 board is the test platform. Most people prefer to connect
up the hardware and program some sample files on to the board using AVRISP, before
tackling writing code in AVRStudio. However, it is up to you.
Another good starting point is to read Get Going with… AVR book in Kanda AVR folder
first, especially if your experience with microcontrollers is limited.
The rest of this manual describes how to connect the hardware and use AVRISP. This
is followed by a short description of the STK200 board and finally by a brief introduction
to AVRStudio and JTAGAVR debugger.
The only software you need to start with is AVRISP and AVR Studio. The rest can be
used later if you want to experiment.

Connecting the hardware
Run Kanda AVR.exe from CD BEFORE connecting hardware
1) Connect the ISP dongle to the USB port on your PC. Windows should automatically
install the USB drivers. If it does not install correctly, please see troubleshooting
guide: C:\Program Files\Kanda AVR\AVRISP-U\ Troubleshooting USB Driver
Install.pdf
2) Connect the 10-way ISP lead to the PC Adapter or dongle
3) Connect the 10-way ISP lead to the STK200 board – see diagram.
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RS232
On/Off Power Connector
Switch Connector

Programming
Interface

Port Headers

Make sure you use the correct header on the STK200 board – it is the box header next
to the 9-way D-Type connector and power input.
If you have the ICE version, AVRISP uses the lead marked ISP Only

Power Supply
4) Connect a power supply to the board. The connector type required is 2.1mm barrel,
centre negative or centre positive. It can be 7-12VAC or 9-15VDC, with a current
capacity greater than 300mA.

AVRISP software
Now run the AVRISP software and it should detect an Atmega16, which you select.
• You can change device in the Device drop down list
• A Green Light should appear at the bottom of the screen with the message ISP
Initialized : Detected Device Atmega16
If a RED light appears on the status line, then check the following
1)
2)
3)
4)

The AVRISP is connected to the board as shown above
The board is powered
AVR appears in Programmer box at top of screen
Atmega16 is in ADC socket, correct way round
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Load File
Once the board is connected properly, the next step is to load a file into the buffer. All
operations are carried out on the data in the buffers. There are two buffers, one for code
– Flash and one for data – EEPROM. Both are loaded with .HEX files, which are the
output files from the assembler or C compiler.
Go to File Menu and choose Load > Flash, and select a file such as Samples > STK200
> LED Flash > LEDflash.hex
To load EEPROM data, follow the same procedure or type data directly into the buffer, in
Hex numbers or ASCII characters.
Programming the AVR
All operations on the AVR chip are carried out from the Device Menu.

Note: AVR devices must be erased first if they have been programmed before.
To program and run the example file we have loaded into the buffer on to the STK200,
1) Choose Device > Erase – always erase before reprogramming
2) Choose Device > Program > Flash
3) Choose Device > Run – Run releases the chip from ISP so it can run its code
The LEDs on the board should begin to flash. Follow this procedure to program other
code into the AVR on the STK200 board.
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AVR microcontroller default fuses
New AVR devices come with the Clock Source set to RC Internal Oscillator by default.
The actual speed of the oscillator varies from 0.5MHz to 4MHz depending on the device,
1MHz on Atmega16. This means that programs will run slower than expected, because
the AVR is NOT running from the 8MHz clock on the STK200 board.
To change the Clock source, go to Fuses and Lockbits tab and change CLKSEL fuses
from Internal Oscillator to External Crystal/Resonator 3 – 8MHz (1110 or 1111). Then go
to Device menu > Program > Fuses.
Other features of AVRISP
Auto Program
It can get a bit tedious carrying out all these steps individually, especially if you want to
check that the code has loaded properly (Verify) and program the EEPROM as well. This
is where Device > Auto Program (F5 key) is useful.
To use Auto Program feature, first go to Device > Auto Program Options and set the
operations you want to carry out. Now selecting Device > Auto Program or pressing F5
will carry out all these operations.
Auto program is especially useful if you call the programmer from AVRStudio. Make sure
Reload Files is checked in Auto-program Options, and you just need to click on
AVRISP-U and hit F5 key if you recompile your project in AVRStudio.
Fuses and Lockbits
Click on the Fuses and Lockbits Tab to view the Fuse screen. These are settings on the
AVR devices that can be altered to affect the way the device runs and interacts with the
circuit.
The default fuses will work happily on the STK200 board, but you may want to alter them
to make the clock run from the 8MHz crystal on the board. JTAGEN fuse should also be
left checked for JTAG ICE emulator. Full descriptions of each fuse and what they do are
in the device datasheets – see AVR Datasheets folder on second CD for the datasheets
on each AVR.
On the right of the Fuse screen is a second tab marked Lockbits and Boot Options. This
screen displays the various security settings and block options available. Again, these
are described in the AVR datasheets.
Status
The Status Tab lists the operations that have been carried out during the current
programming session.
Serial Numbers
Serial numbers can be added to the Code space (Flash) or Data Memory (EEPROM) in
a variety of formats. If Auto Program is used, the serial number will increment with every
Auto-program cycle.
View Menu
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CRC Checksums
This gives the checksum calculations in different formats for the whole buffer or just the
used buffer. Applies to both Flash and EEPROM
Pop-up Warnings
This displays a message box if there is a verify error. Useful if repeated Auto Program
operations are carried out, when it can be easy to ignore errors.
Setup
This can also be selected by clicking the Setup Button. It covers a variety of settings,
which are not needed on STK200 board but are useful for your own circuits, especially if
they have slower clocks, big capacitors or lower voltage..
Reset Button
This is used to Reset the AVR on the board. This is a way of resetting communications if
errors occur or the programmer cannot find the chip.

STK200 Board Description
The schematics of the board are available in the Documentation > STK200 folder in the
install folder. A full description of the board is given in STK200 manual.pdf
Voltage Selection
There is one jumper – JP1 – for setting the board voltage. If the jumper is on, the board
operates at 5V. If it is off, the board operates at 3.3V.
Notes:
1) If the board is set to 3.3V, the brownout circuit should be set to 2.9V by removing
JP2
2) The ISP interface is supplied with 5V regardless of the board voltage.
3) The AVR device supplied as standard can operate from 2.7-5.5V
Brownout Circuit
The STK200 has a brownout detector to reset the AVR if the voltage drops too low. The
brownout level is set using JP2 and should match the voltage selected by JP1 i.e. JP1
and JP2 both off or both on.
Clock Circuit
The board uses an 8MHz crystal connected to a 74HC00 external clock chip. The clock
signal is connected to XTAL1 pin on AVR chip.
Serial Port
The AVR devices supplied have an hardware USART. It is connected through a
MAX202 chip to give RS232 level signals.
USART0 (RXD0/TXD0) is connected to the female 9-way D-Type connector.
The USART is also available, at TTL levels, on the expansion headers on the edge of
the board .
Details about Baud Rates, control and other settings are in AVR datasheets.
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Expansion Headers
All the device port pins are brought-out to pin headers on the edge of the board. The
layout of these connectors is shown below. Full details are in STK200 manual.pdf
Edge of Board

0

1

2

3

4

5

6

7

GND

VCC

LCD Circuit
The 14 x 1 header marked LCD is for a standard 2 X 16 character LCD. The
connections are shown on the board and in the following table. The LCD display is fitted
with the display side facing out from the board
Connection Name
0V
+5
Vo
RS
Wr
E
D0
D1
D2
D3
D4
D5
D6

Function
Ground 0V
Vcc - must be 5V
Contrast
Register Select- A14
Not Write
Enable
Data Bit 0
Data Bit 1
Data Bit 2
Data Bit 3
Data Bit 4
Data Bit 5
Data Bit 6

D7

Data Bit 7
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STK200 or STK300
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The board is designed for use with an LCD with a Hitachi driver chip built-in, with a
contrast pin voltage of 0 to 5 Volts. If no characters appear on LCD, then you may need
to change resistors R22 and R23 to alter the contrast voltage, especially if you use a
different LCD.
This board is not designed for use with back lit LCD modules, so the extra connections
needed are not included and the power supply will not supply the current required.
The LCD can be driven in Memory Mapped or I/O Mode - see data sheet. If the crystal
has been changed to a faster crystal frequency, memory mapped operations will not
work.
A suitable LCD is available on the Kanda site (http://www.kanda.com/go/570910-PM)
Sample files for memory mapped and direct I/O operation are included on the CD in
Samples directory.
External Memory
The board is fitted with sockets for an address latch (74HC573) and a Flash RAM chip
(29C256). These are available as a pair from Kanda –
http://www.kanda.com/go/STK200-RAM

29C256 Pin-outs

24C EEPROM Socket
The board is fitted with a socket for 24C EEPROM Chip. This is an I2C device, or in
Atmel speak, a Two Wire Serial Interface (TWI).
The socket is connected to SCL and SDA pins on the AVR microcontroller.
The socket layout is shown below.
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A full description of the TWI is given in the AVR datasheet.
Note: Pull-ups must be enabled on these two lines, PORTC.0 and 1
Switches and Bar LED
There is a 10-way bar LED fitted to the board.
•
•

One LED is Power (labeled ON), and should be on when the board is powered.
The next LED is labeled ISP and should be on when the board is in ISP mode.

Note: The AVR will not run its code if the board is in ISP mode. To exit ISP on run your
code, choose Device > Run command or disconnect the ISP lead from the board
•

The other 8 LEDs (0-7) are for user code. They are active low (0 switches them On),
and they are connected to a 10-way header marked LED’S. A short 10-way lead
connects this header to the Port B header by default. Move the lead to another Port
header if you want to use a different AVR Port for LED output.

The 8 switches are also active low (0 when pressed), and are connected to the 10-way
header marked SWITCHES. A 10-way ribbon cable connects them to Port D by default.
Again, move the cable to another header if a different port is required.
Both the LED and SWITCH headers also have GRD and VCC pins.
Note: AVR ports have three registers controlling them:
1) Port – value to write
2) DDR – direction register (0 is input)
3) Pin – value to read
So, to read switches, set DDR register to 0 and read PIN register – 0 is switch pressed.
To write to LEDs, set DDR to 0xFF and write values to Port register, where 0 is on.
Summary
There is sample code in the install folder. The board schematics are also available in
Kanda AVR folder.
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AVR Studio 4
AVR Studio is Atmel’s development environment. Documentation is available in the AVR
Studio folder in C:\Program Files\Kanda AVR\AVR Studio\Documentation.
There is a sub-folder called Documentation that contains
• Getting started guide. This explains how to set up AVR Studio and create programs.
• Instruction set guide, that lists the AVR instruction set
• Tools set up guide, which explains how to add AVRISP to AVR Studio Tools menu if
it is not already added
Here is a brief guide to using one of the sample files in AVR Studio, but more information
is available in the Getting Started guide and at www.atmel.com
AVR Studio is project based, so you need to create a project before you can do
anything. Follow this procedure.
1) Run AVRStudio and select New Project from Welcome screen. If Welcome screen
does not appear, select Project Menu > Project Wizard
2) Choose Atmel AVR Assembler as Project Type. See note and end of this section for
C Projects.
3) Give the Project a name
4) Uncheck Create Initial File box
5) Set location of where to save Project files

6) Click Next Button
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On the next screen,
1) Set Debug platform JTAG ICE.
2) Set Device to Atmega16
3) Click Finish Button

Now the project is created, we need to add a sample file.
1) The Project is displayed at the left of the screen. Right click on the Project name and
choose Add Files to Project

2) Select an assember file from Sample Code > STK200 folder in Kanda AVR folder,
such as LedFlash200.asm
3) Now go to Build Menu > Build. This will assemble the file and create object code file
(.hex) for AVRISP programmer.
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Running AVRISP from AVR Studio
AVRISP will be added to AVR Studio Tools menu, if it is installed after AVR Studio. The
Kanda AVR installer will install them in the correct order.
To run AVRISP from AVR Studio, go to Tools Menu > Kanda Tools > AVRISP-U
AVRISP will open a project with the correct files and device choice, using your AVR
Studio project. It will also set Auto-program Options to
• Reload File
• Erase
• Program and Verify Flash
• Program and Verify EEPROM, if an EEPROM file exists
• Run the device
This means that you just need to use Auto-Program (F5) in AVRISP software to load
your code into the AVR on the STK200 board, once you have built it, or re-built it..

AVR Studio 4 C Projects
Winavr (on CD) is a C Compiler for AVR. When you run AVR Studio you can select
project type as AVR GCC – use this for WinAVR. If Winavr is not installed, AVRStudio
will prompt for installation.
There are example C Projects in Sample Code folder in Kanda AVR folder. Create a
project without creating an initial file and then add a C file as source file, just like
assembler.
Alternatively, you can open a C project file (*.aps) from C Sample code folder.
Important
The C compiler is a plug-in for AVR Studio and is not directly controlled by it, so there
are some important points to be aware of
1. C projects must have AVR device set correctly, unlike assembler files which are not
so fussy, otherwise code will not run.
2. Changing device in AVR Studio project does NOT change device in C compiler. You
need to go to Project > Configuration Options and change device there as well.
Also on this screen, make sure Create Hex File is checked.
3. Output files are stored in a sub-folder called Default
Embedded C Book
There is a PDF book on Embedded C Programming in Embedded C Book folder. It
covers the basics of writing C for AVR microcontrollers but uses IAR C compiler instead
of WinAVR and AVR Studio. A free 4KB limited version of the IAR compiler, called Kick
Start, is available for download. It is similar to WinAVR but produces smaller code and
has lots of advanced features.
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AVR Studio 6
AVRSudio 6 can be downloaded for free from www.atmel.com, you just need to register.
It is large, about 750 MB and needs a fast PC. All the example code will work but needs
a bit of tweaking.

C Projects
As all projects are for AVRStudio 4, you will need to import them rather than use Open.
File menu -> Import -> AVRStudio 4 Project

AVRStudio 6 will create a Solution, which is the new fancy name for a project. The rest
of the instructions are the same.

Assembler Projects
Create a new Assembler Project/solution and use one of the sample files as the main
file.

Using AVRISP-U with AVRStudio 6
You will need to add AVRISP-U to the Tools menu -> External Tools. See Adding
AVRISP-U to AVRStudio.pdf in AVRISP-U folder.
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Using JTAGICE with STK200
If you have the JTAGAVR Tool as part of the package or you have purchased it
separately, then it is simple to use with the ST200 board. Please note that the JTAGAVR
is an In Circuit Emulator and not primarily a programmer, so AVRISP is still used as a
separate tool.
Using JTAGAVR with AVR Studio
You can check that project device is set to JTAG ICE and Atmega16 in Debug Menu >
Select Platform and Device.

The list of available devices is very small with JTAGICE, which is an Atmel marketing
decision. For more device support, you will need AVR Dragon or ICE3. Choose
Atmega16 as device.
The Port setting on this screen defaults to Auto. This means that AVR Studio will scan all
Serial Ports looking for the ICE tool, including Virtual Serial Ports used by USB. It only
looks on COM1 to 4 in some versions of AVR Studio, more information in JTAGAVR
Quick Start Guide in Documentation > ICE folder
Connecting JTAGAVR to STK200 Board
1) Connect the JTAGAVR Tool to the PC serial port (or use a USB to Serial cable).
Users with USB version should just connect directly to USB Port
2) Connect the 10-way ribbon cable to the JTAGAVR
3) Connect adapter A to the end of the 10-way lead for Atmega162 OR Adapter B for
Atmega16
4) Plug the adapter into PORT C header on the STK200 board, with headers facing in
towards the board
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JTAGAVR Documentation
JTAGAVR uses AVR Studio software, so no extra software needs installing. There is
documentation on the tool. It is in a Folder called ICE, in Documentation folder.
These PDF files give more detail about using the JTAG AVR or JTAG ICE tool.
Firmware Updates
If you change AVR Studio to a different version or install a new Service Pack, then it
may want to do a firmware update using the built-in AVRProg software. Serial port
versions of JTAGAVR will update fine but USB versions will not be found by AVRProg,
because it only looks at COM1 to COM4. See JTAGAVR Quick Start Guide in
Documentation > ICE folder for details on changing COM Port setting.

Application Builder
Application or App Builder is found in its own folder in Kanda AVR folder in program
Files, or it can be launched from desktop icon. There is a manual in this folder as well.
App Builder creates setup code for any selected peripheral, including interrupts and port
settings needed.
Outputs can be in C or assembler. Once an output file is created, it can be opened in
AVRStudio just like any other sample code.

Conclusion
This guide has briefly described the main features of the STK200 package. There is
more information about AVR Studio on the CD, in its Help file and online at
www.atmel.com

AVRISP has a help file, and there are AVR datasheets and instruction set
documentation on the CD.
The other packages on the CD have help and documentation included.
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Further Information
More information about AVR code and programming can be found online
•

www.avrfreaks.com – a forum and help site for AVR

•

www.kanda.com/support – new software versions, FAQ and documents about AVR and

kanda tools
•

www.atmel.com/products/avr - more information about AVR microcontrollers

•

Books are available at Amazon. Kanda supply a basic book at
www.kanda.com/go/KB0010

Other tools and accessories
We supply add-ons for the STK200, including LCD modules, keypads, Flash RAM, 24C
EEPROMs, extra AVR devices, ICE and a universal power supply.
•

AVR Dragon emulator for more devices and AVRStudio6 support
www.kanda.com/go/AVR-DRAGON

•

Flash RAM and Address Latch – see www.kanda.com/go/STK200-RAM

•

LCD module – see www.kanda.com/go/570910-PM

•

Data Entry Keypad – see www.kanda.com/go/780305-PM

•

JTAGAVR ICE – see www.kanda.com/go/JTAGAVR

•

Power supply – see www.kanda.com/go/PSU9V-UNI

•

AVR devices – see www.kanda.com/go/AVR-MAIN

•

24C Serial EEPROM – see www.kanda.com/go/EE-02
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Website: www.kanda.com
Email: sales@kanda.com
Tech support: support@kanda.com
Support Pages: www.kanda.com/support
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Phone: +44 (0) 1974 261 273
Fax: +44 (0) 1974 261 273
Address
Canolafan
Llanafan
Aberystwyth
SY23 4AY
UK
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