Compile error with AVR Studio

Home Forums Kanda Forums Technical Support Forums Compile error with AVR Studio

This topic is: not resolved

Notice: get_currentuserinfo is deprecated since version 4.5.0! Use wp_get_current_user() instead. in /home/kanda/public_html/blog/wp-includes/functions.php on line 4648
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #332
    AvatarSimon
    Participant

    I am using AVRStudio 4.19, and when I compile I get the following error:

    avr-objcopy: ‘PWM.elf’: No such file

    How can I resolve this issue?

    #333
    AvatarKanda Admin
    Keymaster
    Post count: 324

    You need to manually set up the paths to the tool chain because Atmel have a bug in AVRStudio 4.19.

    Go to Project -> Configuration Options -> Custom Options.
    Untick the “Use AVR toolchain” box and set the paths to:

    avr-gcc: C:\WinAVR-20100110\bin\avr-gcc.exe
    make: C:\WinAVR-20100110\utils\bin\make.exe

    #385
    AvatargeorgeC
    Participant
    Post count: 1

    thanks, i was also getting this error, studio help was no good

    #413
    AvatarSamrinG
    Participant
    Post count: 2

    This was also my problem but it did not gicve this error, it said syntax wrong in makefile when i build it, so i tried adding the paths you give and it workd

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Microcontrollers, training, electronics and coding


Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /home/kanda/public_html/blog/wp-includes/functions.php on line 4552